Binance API does not work

Marvin

Member
Joined
Apr 30, 2020
Posts
11
Likes
0
Hello everybody,

I was under the impression that Motivewave was supposed to work with a Binance Spot account. I currently can connect to my Binance account, but I am receiving numerous errors when placing orders.

Is anybody having any luck with this connection?

Thanks,

Marvin
 

Marvin

Member
Joined
Apr 30, 2020
Posts
11
Likes
0
Hopefully support/dev team can get Binance up and running for us. I can see the Binance charts and my account balance through the API but as soon as I try to place a trade I get tons of errors and I have to login to my real Binance account to close the trades. Could Dev get on this please??

Marvin
 

Essaidovski

Member
Joined
Dec 6, 2020
Posts
21
Likes
0
Hopefully support/dev team can get Binance up and running for us. I can see the Binance charts and my account balance through the API but as soon as I try to place a trade I get tons of errors and I have to login to my real Binance account to close the trades. Could Dev get on this please??

Marvin
In the beginning , i never managed to place a trad in Binance with Motivewave . always having errors 😠
Now it's impossible to access my account 🤔😢. I have to login to my real Binance account to Trad .
N o response from the MW support team for a week. 😠😠
 

Stoneyard

Member
Joined
Feb 26, 2021
Posts
6
Likes
0
Hi Marvin, I did have some problems myself too! I tried to look at the log to find out why, but could find the reason why. So after many changes of API Keys for no reason it started working!
Here is the latest Log (You should get something similar) Look for it in HELP then Log File.
I hope it helps!

Regards,
P.S. Try connecting with Binance alone and then test adding Binance & Crypto Compare at the same time. See how the log react. If both fail the issue will be different.
P.P.S. My problem now is Keeping the connection running so that the active Strategy doesn't lose a trade. The connection was lost or stopped for no reason I can explain. (Using the Cloud)

Stoneyards

16:32:23 INFO Connecting to: Binance
...
16:33:48 INFO connected to Binance
16:33:48 INFO Connecting to: Bitstamp
16:33:57 WARNING unable to connect!
16:33:57 INFO Connecting to: CryptoCompare
16:34:00 WARNING {"MESSAGE":"INVALID_PARAMETER","INFO":"We only support JSON format with a valid api_key, you did not pass an api_key or your api_key is invalid so you can only use streamer format.","TYPE":"401","PARAMETER":"format"}
16:34:00 WARNING CCService::eek:nDisconnected()
16:34:00 WARNING Service::reconnect() scheduling reconnect in 2 seconds (CryptoCompare)
16:34:01 INFO connected to CryptoCompare
....
 

Daveman0

Member
Joined
Mar 6, 2021
Posts
8
Likes
1
Oy, lots of bugs on my end here as well - any luck with any solutions? Currently API keys are being rejected as invalid after working for a few days... Seems like a buggy match right now...
 

Stoneyard

Member
Joined
Feb 26, 2021
Posts
6
Likes
0
Oy, lots of bugs on my end here as well - any luck with any solutions? Currently API keys are being rejected as invalid after working for a few days... Seems like a buggy match right now...
Try Updating your clock time
 

Stoneyard

Member
Joined
Feb 26, 2021
Posts
6
Likes
0
Oy, lots of bugs on my end here as well - any luck with any solutions? Currently API keys are being rejected as invalid after working for a few days... Seems like a buggy match right now...
Mine was set to re-sync every once in a while but every time it disconnect it seems to be the cause!
 

Stoneyard

Member
Joined
Feb 26, 2021
Posts
6
Likes
0
Updating clock time to...? Thanks for your help!
Left click on your computer clock (probably bottom right corner of your screen) Then click on Modify then Internet time, force next synchronization to right now! After that login MW and try the same API keys for connection
 

Daveman0

Member
Joined
Mar 6, 2021
Posts
8
Likes
1
Hmm... I'm on OSX Big Sur... Tried synching my system clock to a different server - still getting this error:

18:46:46 WARNING BNService::connect() unable to load spot account: 401 {"code":-2015,"msg":"Invalid API-key, IP, or permissions for action."}
 

Stoneyard

Member
Joined
Feb 26, 2021
Posts
6
Likes
0
Hmm... I'm on OSX Big Sur... Tried synching my system clock to a different server - still getting this error:

18:46:46 WARNING BNService::connect() unable to load spot account: 401 {"code":-2015,"msg":"Invalid API-key, IP, or permissions for action."}
Mine is on time.nist.gov (if it helps) The other thing could be to reset a new pair of keys after that ! Good luck!
 

Pejman

Active member
Joined
May 22, 2019
Posts
39
Likes
6
HI All

i could connect to Binance but it just shows 12 symbols, is it limitation of Binance or software?
 
Top